CVE-2025-54539
Apache ActiveMQ NMS AMQP Client has a Deserialization of Untrusted Data vulnerability
Sévérité par source
Le label propre à Trivy est CRITICAL. Critique selon GHSA.
Description
A Deserialization of Untrusted Data vulnerability exists in the Apache ActiveMQ NMS AMQP Client. This issue affects all versions of Apache ActiveMQ NMS AMQP up to and including 2.3.0, when establishing connections to untrusted AMQP servers. Malicious servers could exploit unbounded deserialization logic present in the client to craft responses that may lead to arbitrary code execution on the client side. Although version 2.1.0 introduced a mechanism to restrict deserialization via allow/deny lists, the protection was found to be bypassable under certain conditions. In line with Microsoft’s deprecation of binary serialization in .NET 9, the project is evaluating the removal of .NET binary serialization support from the NMS API entirely in future releases. Mitigation and Recommendations: Users are strongly encouraged to upgrade to version 2.4.0 or later, which resolves the issue. Additionally, projects depending on NMS-AMQP should migrate away from .NET binary serialization as part of a long-term hardening strategy.
Paquets affectés et versions corrigées
| Source | Paquet | Corrigé en |
|---|---|---|
| nuget::GitHub Security Advisory NuGet | Apache.NMS.AMQP, apache.nms.amqp | 2.4.0 |
Afficher les 2 entrées d'une source
| Source | Paquet | Corrigé en |
|---|---|---|
| nuget::GitHub Security Advisory NuGet | Apache.NMS.AMQP | 2.4.0 |
| nuget::GitHub Security Advisory NuGet | apache.nms.amqp | 2.4.0 |