Vulnérabilités / CVE-2023-33966

critique

CVE-2023-33966

Missing "--allow-net" permission check for built-in Node modules

Publiée Modifiée CWE 269, 276
Dans la Trivy database depuis au moins le 24 oct. 2026, 07:11 UTCLa date d'entrée avant ce build n'est pas enregistrée.

Sévérité par source

NVD9.8CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
GHSA8.6CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:N/I:H/A:N

Le label propre à Trivy est CRITICAL. Critique selon NVD. Plus basse selon GHSA (élevée).

Description

Deno is a runtime for JavaScript and TypeScript. In deno 1.34.0 and deno_runtime 0.114.0, outbound HTTP requests made using the built-in `node:http` or `node:https` modules are incorrectly not checked against the network permission allow list (`--allow-net`). Dependencies relying on these built-in modules are subject to the vulnerability too. Users of Deno versions prior to 1.34.0 are unaffected. Deno Deploy users are unaffected. This problem has been patched in Deno v1.34.1 and deno_runtime 0.114.1 and all users are recommended to update to this version. No workaround is available for this issue.

Paquets affectés et versions corrigées

SourcePaquetCorrigé en
cargo::GitHub Security Advisory Rustdeno, deno_runtime1.34.1 et 1 autres
Afficher les 2 entrées d'une source
SourcePaquetCorrigé en
cargo::GitHub Security Advisory Rustdeno1.34.1
cargo::GitHub Security Advisory Rustdeno_runtime0.115.0

Références

Vulnerability data compiled from the Trivy vulnerability database (trivy-db, Aqua Security, Apache License 2.0), which aggregates third-party advisories. CVE records are published by The MITRE Corporation under the CVE Terms of Use; CVE is a trademark of MITRE. This product uses data from the NVD API but is not endorsed or certified by the NVD. Severity, titles and advisory data from the GitHub Advisory Database (CC BY 4.0), Red Hat security data (CC BY 4.0) and the other sources linked on each entry. Entries may be summarised or re-formatted; the linked original is the authoritative record.