CVE-2023-20873
spring-boot: Security Bypass With Wildcard Pattern Matching on Cloud Foundry
Sévérité par source
Le label propre à Trivy est CRITICAL. Critique selon NVD, GHSA. Plus basse selon Red Hat (élevée).
Description
In Spring Boot versions 3.0.0 - 3.0.5, 2.7.0 - 2.7.10, and older unsupported versions, an application that is deployed to Cloud Foundry could be susceptible to a security bypass. Users of affected versions should apply the following mitigation: 3.0.x users should upgrade to 3.0.6+. 2.7.x users should upgrade to 2.7.11+. Users of older, unsupported versions should upgrade to 3.0.6+ or 2.7.11+.
Paquets affectés et versions corrigées
| Source | Paquet | Corrigé en |
|---|---|---|
| maven::GitHub Security Advisory Maven | org.springframework.boot:spring-boot-actuator-autoconfigure | 3.0.6, 2.7.11, 2.6.15, 2.5.15 |
| Red Hat | spring-boot | pas de correctif indiqué |
Références
- https://access.redhat.com/security/cve/CVE-2023-20873
- https://github.com/advisories/GHSA-g5h3-w546-pj7f
- https://github.com/spring-projects/spring-boot
- https://github.com/spring-projects/spring-boot/commit/32444fed4b51cc58dc908467f706102d7f0bfc15
- https://github.com/spring-projects/spring-boot/commit/3522714c13b47af03bf42e7f2d5994af568cb1a7
- https://github.com/spring-projects/spring-boot/releases/tag/v2.5.15
- https://github.com/spring-projects/spring-boot/releases/tag/v2.6.15
- https://github.com/spring-projects/spring-boot/releases/tag/v2.7.11
Les 16 références
- https://github.com/spring-projects/spring-boot/releases/tag/v3.0.6
- https://nvd.nist.gov/vuln/detail/CVE-2023-20873
- https://security.netapp.com/advisory/ntap-20230601-0009
- https://security.netapp.com/advisory/ntap-20230601-0009/
- https://spring.io/blog/2023/05/18/spring-boot-2-5-15-and-2-6-15-available-now
- https://spring.io/security/cve-2023-20873
- https://spring.io/security/cve-2023-20873/
- https://www.cve.org/CVERecord?id=CVE-2023-20873