CVE-2020-5211
In NetHack before 3.6.5, an invalid extended command in value for the ...
Sévérité par source
Le label propre à Trivy est CRITICAL. Critique selon NVD. Plus basse selon Ubuntu (faible).
Description
In NetHack before 3.6.5, an invalid extended command in value for the AUTOCOMPLETE configuration file option can cause a buffer overflow resulting in a crash or remote code execution/privilege escalation. This vulnerability affects systems that have NetHack installed suid/sgid and shared systems that allow users to upload their own configuration files. Users should upgrade to NetHack 3.6.5.
Paquets affectés et versions corrigées
| Source | Paquet | Corrigé en |
|---|---|---|
| debian 11 | nethack | 3.6.6-1 |
| debian 12 | nethack | 3.6.6-1 |
| debian 13 | nethack | 3.6.6-1 |
| debian 14 | nethack | 3.6.6-1 |
| echo | nethack | 3.6.6-1 |
| ubuntu 18.04-ESM | nethack | pas de correctif indiqué |
| ubuntu 20.04-ESM | nethack | pas de correctif indiqué |