CVE-2026-8838
amazon-redshift-python-driver vulnerable to Remote Code Execution via eval() Injection
Severidad por fuente
La etiqueta propia de Trivy es CRITICAL. Crítica según GHSA.
Descripción
Unsafe use of Python's eval() on server-received data in the vector_in() function in amazon-redshift-python-driver before 2.1.14 allows a rogue server or man-in-the-middle actor to execute arbitrary code on the client. To remediate this issue, users should upgrade to version 2.1.14.
Paquetes afectados y versiones corregidas
| Fuente | Paquete | Corregido en |
|---|---|---|
| pip::GitHub Security Advisory pip | redshift-connector | 2.1.14 |
| chainguard | airflow-3 | 3.2.1-r4 |
| echo pip::Echo OSV | redshift-connector | 2.1.14 |
| minimos | airflow-3 | 3.2.2-r0 |
| wolfi | airflow-3 | 3.2.1-r4 |
Referencias
- https://advisory.echohq.com/cve/CVE-2026-8838
- https://aws.amazon.com/security/security-bulletins/2026-033-aws
- https://aws.amazon.com/security/security-bulletins/2026-033-aws/
- https://github.com/aws/amazon-redshift-python-driver
- https://github.com/aws/amazon-redshift-python-driver/commit/69a69dfdead75918e20384da52bcd760ded8dbca
- https://github.com/aws/amazon-redshift-python-driver/releases/tag/v2.1.14
- https://github.com/aws/amazon-redshift-python-driver/security/advisories/GHSA-29h4-r29x-hchv
- https://nvd.nist.gov/vuln/detail/CVE-2026-8838