CVE-2025-68665
langchain-core: LangChain: Arbitrary Code Execution via Serialization Injection
Severidad por fuente
La etiqueta propia de Trivy es CRITICAL. Crítica según NVD. Más baja según GHSA (alta), Red Hat (alta).
Descripción
LangChain is a framework for building LLM-powered applications. Prior to @langchain/core versions 0.3.80 and 1.1.8, and prior to langchain versions 0.3.37 and 1.2.3, a serialization injection vulnerability exists in LangChain JS's toJSON() method (and subsequently when string-ifying objects using JSON.stringify(). The method did not escape objects with 'lc' keys when serializing free-form data in kwargs. The 'lc' key is used internally by LangChain to mark serialized objects. When user-controlled data contains this key structure, it is treated as a legitimate LangChain object during deserialization rather than plain user data. This issue has been patched in @langchain/core versions 0.3.80 and 1.1.8, and langchain versions 0.3.37 and 1.2.3
Paquetes afectados y versiones corregidas
| Fuente | Paquete | Corregido en |
|---|---|---|
| chainguard | kibana-8.17, kibana-8.18, kibana-8.19 y 6 más | 8.17.10-r6 y 7 más |
| echo npm::Echo OSV | @langchain/core, langchain | 0.3.37 |
| minimos | kibana-8.19, kibana-9.2, kibana-9.3 | 8.19.15-r0 y 2 más |
| npm::GitHub Security Advisory npm | @langchain/core, langchain | 1.1.8, 0.3.80 y 1 más |
Mostrar las 16 entradas de 4 fuentes
| Fuente | Paquete | Corregido en |
|---|---|---|
| chainguard | kibana-8.17 | 8.17.10-r6 |
| chainguard | kibana-8.18 | 8.18.8-r6 |
| chainguard | kibana-8.19 | 8.19.9-r2 |
| chainguard | kibana-9.0 | 9.0.8-r5 |
| chainguard | kibana-9.1 | 9.1.9-r1 |
| chainguard | kibana-9.2 | 9.2.3-r1 |
| chainguard | langfuse-2 | 2.95.12-r4 |
| chainguard | langfuse-fips-2 | 2.95.12-r4 |
| chainguard | librechat | 0.8.1-r1 |
| echo npm::Echo OSV | @langchain/core | 0.3.37 |
| echo npm::Echo OSV | langchain | 0.3.37 |
| minimos | kibana-8.19 | 8.19.15-r0 |
| minimos | kibana-9.2 | 9.2.5-r0 |
| minimos | kibana-9.3 | 9.3.4-r0 |
| npm::GitHub Security Advisory npm | @langchain/core | 1.1.8, 0.3.80 |
| npm::GitHub Security Advisory npm | langchain | 1.2.3, 0.3.37 |
Referencias
- https://access.redhat.com/security/cve/CVE-2025-68665
- https://advisory.echohq.com/cve/CVE-2025-68665
- https://github.com/advisories/GHSA-r399-636x-v7f6
- https://github.com/langchain-ai/langchainjs
- https://github.com/langchain-ai/langchainjs/commit/e5063f9c6e9989ea067dfdff39262b9e7b6aba62
- https://github.com/langchain-ai/langchainjs/releases/tag/@langchain%2Fcore@1.1.8
- https://github.com/langchain-ai/langchainjs/releases/tag/langchain@1.2.3
- https://github.com/langchain-ai/langchainjs/security/advisories/GHSA-r399-636x-v7f6