CVE-2025-25196
OpenFGA Authorization Bypass
Severidad por fuente
La etiqueta propia de Trivy es CRITICAL. Crítica según NVD. Más baja según GHSA (media).
Descripción
OpenFGA is a high-performance and flexible authorization/permission engine built for developers and inspired by Google Zanzibar. OpenFGA < v1.8.4 (Helm chart < openfga-0.2.22, docker < v.1.8.4) are vulnerable to authorization bypass when certain Check and ListObject calls are executed. Users on OpenFGA v1.8.4 or previous, specifically under the following conditions are affected by this authorization bypass vulnerability: 1. Calling Check API or ListObjects with a model that has a relation directly assignable to both public access AND userset with the same type. 2. A type bound public access tuple is assigned to an object. 3. userset tuple is not assigned to the same object. and 4. Check request's user field is a userset that has the same type as the type bound public access tuple's user type. Users are advised to upgrade to v1.8.5 which is backwards compatible. There are no known workarounds for this vulnerability.
Paquetes afectados y versiones corregidas
| Fuente | Paquete | Corregido en |
|---|---|---|
| chainguard | grafana-11.3, grafana-11.4, grafana-11.5 y 2 más | 11.3.9-r5 y 3 más |
| go::GitHub Security Advisory Go | github.com/openfga/openfga | 1.8.5 |
| minimos | grafana-11.4, grafana-11.5 | 11.4.3-r0 y 1 más |
Mostrar las 8 entradas de 3 fuentes
| Fuente | Paquete | Corregido en |
|---|---|---|
| chainguard | grafana-11.3 | 11.3.9-r5 |
| chainguard | grafana-11.4 | 11.4.8-r2 |
| chainguard | grafana-11.5 | 11.5.2-r1 |
| chainguard | grafana-fips-11.4 | 11.4.8-r2 |
| chainguard | grafana-fips-11.5 | 11.5.10-r0 |
| go::GitHub Security Advisory Go | github.com/openfga/openfga | 1.8.5 |
| minimos | grafana-11.4 | 11.4.3-r0 |
| minimos | grafana-11.5 | 11.5.3-r0 |