Vulnerabilidades / CVE-2024-52338

crítica

CVE-2024-52338

CVE-2024-52338 affecting package libarrow for versions less than 15.0.0-7

Publicada Modificada CWE 502
En la Trivy database desde, como mínimo, el 24 oct 2026, 07:11 UTCNo consta cuándo entró antes de ese build.

Severidad por fuente

Julia9.8CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

La etiqueta propia de Trivy es CRITICAL. Crítica según Azure Linux, Julia.

Descripción

Deserialization of untrusted data in IPC and Parquet readers in the Apache Arrow R package versions 4.0.0 through 16.1.0 allows arbitrary code execution. An application is vulnerable if it reads Arrow IPC, Feather or Parquet data from untrusted sources (for example, user-supplied input files). This vulnerability only affects the arrow R package, not other Apache Arrow implementations or bindings unless those bindings are specifically used via the R package (for example, an R application that embeds a Python interpreter and uses PyArrow to read files from untrusted sources is still vulnerable if the arrow R package is an affected version). It is recommended that users of the arrow R package upgrade to 17.0.0 or later. Similarly, it is recommended that downstream libraries upgrade their dependency requirements to arrow 17.0.0 or later. If using an affected version of the package, untrusted data can read into a Table and its internal to_data_frame() method can be used as a workaround (e.g., read_parquet(..., as_data_frame = FALSE)$to_data_frame()). This issue affects the Apache Arrow R package: from 4.0.0 through 16.1.0. Users are recommended to upgrade to version 17.0.0, which fixes the issue.

Paquetes afectados y versiones corregidas

FuentePaqueteCorregido en
Azure Linux 3.0ceph, libarrow0:18.2.2-2.azl3 y 1 más
julia::Julia Ecosystem Security AdvisoriesArrow_jll18.1.0+0
chainguardairflow-2, kubeflow-pipelines-visualization-server, superset2.11.0-r15 y 2 más
wolfikubeflow-pipelines-visualization-server, superset2.15.0-r0 y 1 más
Mostrar las 8 entradas de 4 fuentes
FuentePaqueteCorregido en
Azure Linux 3.0ceph0:18.2.2-2.azl3
Azure Linux 3.0libarrow0:15.0.0-7.azl3
julia::Julia Ecosystem Security AdvisoriesArrow_jll18.1.0+0
chainguardairflow-22.11.0-r15
chainguardkubeflow-pipelines-visualization-server2.15.0-r0
chainguardsuperset0
wolfikubeflow-pipelines-visualization-server2.15.0-r0
wolfisuperset0

Referencias

Vulnerability data compiled from the Trivy vulnerability database (trivy-db, Aqua Security, Apache License 2.0), which aggregates third-party advisories. CVE records are published by The MITRE Corporation under the CVE Terms of Use; CVE is a trademark of MITRE. This product uses data from the NVD API but is not endorsed or certified by the NVD. Severity, titles and advisory data from the GitHub Advisory Database (CC BY 4.0), Red Hat security data (CC BY 4.0) and the other sources linked on each entry. Entries may be summarised or re-formatted; the linked original is the authoritative record.