CVE-2024-27135
apache-pulsar: Improper Input Validation in Pulsar Function Worker allows Remote Code Execution
Severidad por fuente
La etiqueta propia de Trivy es CRITICAL. Crítica según NVD. Más baja según GHSA (alta), Red Hat (alta).
Descripción
Improper input validation in the Pulsar Function Worker allows a malicious authenticated user to execute arbitrary Java code on the Pulsar Function worker, outside of the sandboxes designated for running user-provided functions. This vulnerability also applies to the Pulsar Broker when it is configured with "functionsWorkerEnabled=true". This issue affects Apache Pulsar versions from 2.4.0 to 2.10.5, from 2.11.0 to 2.11.3, from 3.0.0 to 3.0.2, from 3.1.0 to 3.1.2, and 3.2.0. 2.10 Pulsar Function Worker users should upgrade to at least 2.10.6. 2.11 Pulsar Function Worker users should upgrade to at least 2.11.4. 3.0 Pulsar Function Worker users should upgrade to at least 3.0.3. 3.1 Pulsar Function Worker users should upgrade to at least 3.1.3. 3.2 Pulsar Function Worker users should upgrade to at least 3.2.1. Users operating versions prior to those listed above should upgrade to the aforementioned patched versions or newer versions.
Paquetes afectados y versiones corregidas
| Fuente | Paquete | Corregido en |
|---|---|---|
| maven::GitHub Security Advisory Maven | org.apache.pulsar:pulsar-functions-worker | 2.10.6, 2.11.4, 3.0.3, 3.1.3, 3.2.1 |
Referencias
- http://www.openwall.com/lists/oss-security/2024/03/12/9
- https://access.redhat.com/security/cve/CVE-2024-27135
- https://github.com/apache/pulsar
- https://lists.apache.org/thread/dh8nj2vmb2br6thjltq74lk9jxkz62wn
- https://nvd.nist.gov/vuln/detail/CVE-2024-27135
- https://pulsar.apache.org/security/CVE-2024-27135
- https://pulsar.apache.org/security/CVE-2024-27135/
- https://www.cve.org/CVERecord?id=CVE-2024-27135