CVE-2024-12029
InvokeAI Deserialization of Untrusted Data vulnerability
Severidad por fuente
La etiqueta propia de Trivy es CRITICAL. Crítica según GHSA.
Descripción
A remote code execution vulnerability exists in invoke-ai/invokeai versions 5.3.1 through 5.4.2 via the /api/v2/models/install API. The vulnerability arises from unsafe deserialization of model files using torch.load without proper validation. Attackers can exploit this by embedding malicious code in model files, which is executed upon loading. This issue is fixed in version 5.4.3.
Paquetes afectados y versiones corregidas
| Fuente | Paquete | Corregido en |
|---|---|---|
| pip::GitHub Security Advisory pip | invokeai | 5.4.3rc2 |
Referencias
- https://github.com/invoke-ai/InvokeAI
- https://github.com/invoke-ai/InvokeAI/commit/ed46acee79460189b38c164321b14bdfbf3073c9
- https://github.com/invoke-ai/invokeai/commit/756008dc5899081c5aa51e5bd8f24c1b3975a59e
- https://github.com/pypa/advisory-database/tree/main/vulns/invokeai/PYSEC-2025-9.yaml
- https://huntr.com/bounties/9b790f94-1b1b-4071-bc27-78445d1a87a3
- https://nvd.nist.gov/vuln/detail/CVE-2024-12029