CVE-2023-31065
Apache InLong Insufficient Session Expiration vulnerability
Severidad por fuente
La etiqueta propia de Trivy es CRITICAL. Crítica según NVD, GHSA.
Descripción
Insufficient Session Expiration vulnerability in Apache Software Foundation Apache InLong.This issue affects Apache InLong: from 1.4.0 through 1.6.0. An old session can be used by an attacker even after the user has been deleted or the password has been changed. Users are advised to upgrade to Apache InLong's 1.7.0 or cherry-pick https://github.com/apache/inlong/pull/7836 https://github.com/apache/inlong/pull/7836 , https://github.com/apache/inlong/pull/7884 https://github.com/apache/inlong/pull/7884 to solve it.
Paquetes afectados y versiones corregidas
| Fuente | Paquete | Corregido en |
|---|---|---|
| maven::GitHub Security Advisory Maven | org.apache.inlong:manager-dao, org.apache.inlong:manager-pojo, org.apache.inlong:manager-service y 1 más | 1.7.0 |
Mostrar las 4 entradas de 1 fuente
| Fuente | Paquete | Corregido en |
|---|---|---|
| maven::GitHub Security Advisory Maven | org.apache.inlong:manager-dao | 1.7.0 |
| maven::GitHub Security Advisory Maven | org.apache.inlong:manager-pojo | 1.7.0 |
| maven::GitHub Security Advisory Maven | org.apache.inlong:manager-service | 1.7.0 |
| maven::GitHub Security Advisory Maven | org.apache.inlong:manager-web | 1.7.0 |