CVE-2023-26053
gradle: usage of long IDs for PGP keys is unsafe and is subject to collision attacks
Severidad por fuente
La etiqueta propia de Trivy es CRITICAL. Crítica según NVD, Bitnami. Más baja según Red Hat (media).
Descripción
Gradle is a build tool with a focus on build automation and support for multi-language development. This is a collision attack on long IDs (64bits) for PGP keys. Users of dependency verification in Gradle are vulnerable if they use long IDs for PGP keys in a `trusted-key` or `pgp` element in their dependency verification metadata file. The fix is to fail dependency verification if anything but a fingerprint is used in a trust element in dependency verification metadata. The problem is fixed in Gradle 8.0 and above. The problem is also patched in Gradle 6.9.4 and 7.6.1. As a workaround, use only full fingerprint IDs for `trusted-key` or `pgp` element in the metadata is a protection against this issue.
Paquetes afectados y versiones corregidas
| Fuente | Paquete | Corregido en |
|---|---|---|
| bitnami::Bitnami Vulnerability Database | gradle | 6.9.4, 7.6.1 |
| alpine 3.17 | gradle | 7.6.1-r0 |
| alpine 3.18 | gradle | 7.6.1-r0 |
| alpine 3.19 | gradle | 7.6.1-r0 |
| alpine 3.20 | gradle | 7.6.1-r0 |
| alpine 3.21 | gradle | 7.6.1-r0 |
| alpine 3.22 | gradle | 7.6.1-r0 |
| alpine 3.23 | gradle | 7.6.1-r0 |
| alpine 3.24 | gradle | 7.6.1-r0 |
| alpine edge | gradle | 7.6.1-r0 |
Referencias
- https://access.redhat.com/security/cve/CVE-2023-26053
- https://github.com/gradle/gradle/commit/bf3cc0f2b463033037e67aaacda31291643ea1a9
- https://github.com/gradle/gradle/security/advisories/GHSA-c724-3xg7-g3hf
- https://nvd.nist.gov/vuln/detail/CVE-2023-26053
- https://security.netapp.com/advisory/ntap-20230413-0002/
- https://www.cve.org/CVERecord?id=CVE-2023-26053