CVE-2019-7139
PRODSECBUG-2198: SQL Injection due to a flaw in MySQL adapter
Severidad por fuente
La etiqueta propia de Trivy es CRITICAL. Crítica según NVD, GHSA.
Descripción
An unauthenticated user can execute SQL statements that allow arbitrary read access to the underlying database, which causes sensitive data leakage. This issue is fixed in Magento 2.1 prior to 2.1.18, Magento 2.2 prior to 2.2.9, Magento 2.3 prior to 2.3.2.
Paquetes afectados y versiones corregidas
| Fuente | Paquete | Corregido en |
|---|---|---|
| composer::GitHub Security Advisory Composer | magento/community-edition | 2.1.18, 2.2.9, 2.3.2 |
| composer::PHP Security Advisories Database | magento/magento1ce, magento/magento1ee, magento/product-community-edition | sin corrección indicada |
Mostrar las 4 entradas de 2 fuentes
| Fuente | Paquete | Corregido en |
|---|---|---|
| composer::GitHub Security Advisory Composer | magento/community-edition | 2.1.18, 2.2.9, 2.3.2 |
| composer::PHP Security Advisories Database | magento/magento1ce | sin corrección indicada |
| composer::PHP Security Advisories Database | magento/magento1ee | sin corrección indicada |
| composer::PHP Security Advisories Database | magento/product-community-edition | sin corrección indicada |
Referencias
- https://github.com/FriendsOfPHP/security-advisories/blob/master/magento/magento1ce/CVE-2019-7139.yaml
- https://github.com/FriendsOfPHP/security-advisories/blob/master/magento/magento1ee/CVE-2019-7139.yaml
- https://github.com/FriendsOfPHP/security-advisories/blob/master/magento/product-community-edition/CVE-2019-7139.yaml
- https://github.com/magento/magento2
- https://magento.com/security/patches/magento-2.3.2-2.2.9-and-2.1.18-security-update-13
- https://magento.com/security/patches/supee-11086
- https://nvd.nist.gov/vuln/detail/CVE-2019-7139
- https://web.archive.org/web/20211206084839/https://magento.com/security/patches/magento-2.3.2-2.2.9-and-2.1.18-security-update-13